about summary refs log tree commit diff
path: root/users/tazjin/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/blog/default.nix')
-rw-r--r--users/tazjin/blog/default.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/users/tazjin/blog/default.nix b/users/tazjin/blog/default.nix
index 6ac89e4665..c8b3c31899 100644
--- a/users/tazjin/blog/default.nix
+++ b/users/tazjin/blog/default.nix
@@ -23,7 +23,7 @@ let
 
   posts = filter includePost (list post (import ./posts.nix));
 
-  rendered = pkgs.runCommandNoCC "tazjins-blog" {} ''
+  rendered = pkgs.runCommandNoCC "tazjins-blog" { } ''
     mkdir -p $out
 
     ${lib.concatStringsSep "\n" (map (post:
@@ -31,13 +31,16 @@ let
     ) posts)}
   '';
 
-in {
+in
+{
   inherit posts rendered config;
 
   # Generate embeddable nginx configuration for redirects from old post URLs
-  oldRedirects = lib.concatStringsSep "\n" (map (post: ''
-    location ~* ^(/en)?/${post.oldKey} {
-      return 301 https://tazj.in/blog/${post.key};
-    }
-  '') (filter (hasAttr "oldKey") posts));
+  oldRedirects = lib.concatStringsSep "\n" (map
+    (post: ''
+      location ~* ^(/en)?/${post.oldKey} {
+        return 301 https://tazj.in/blog/${post.key};
+      }
+    '')
+    (filter (hasAttr "oldKey") posts));
 }