about summary refs log tree commit diff
path: root/users/tazjin/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/blog/default.nix')
-rw-r--r--users/tazjin/blog/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/users/tazjin/blog/default.nix b/users/tazjin/blog/default.nix
index c8b3c31899..60c79f0941 100644
--- a/users/tazjin/blog/default.nix
+++ b/users/tazjin/blog/default.nix
@@ -8,6 +8,7 @@ let
   config = {
     name = "tazjin's blog";
     baseUrl = "https://tazj.in/blog";
+    staticUrl = "https://tazj.in/static/";
 
     footer = ''
       <p class="footer">
@@ -21,9 +22,9 @@ let
 
   inherit (depot.web.blog) post includePost renderPost;
 
-  posts = filter includePost (list post (import ./posts.nix));
+  posts = list post (import ./posts.nix);
 
-  rendered = pkgs.runCommandNoCC "tazjins-blog" { } ''
+  rendered = pkgs.runCommand "tazjins-blog" { } ''
     mkdir -p $out
 
     ${lib.concatStringsSep "\n" (map (post:
@@ -33,7 +34,10 @@ let
 
 in
 {
-  inherit posts rendered config;
+  inherit rendered config;
+
+  # Filter unlisted posts from the index
+  posts = filter includePost posts;
 
   # Generate embeddable nginx configuration for redirects from old post URLs
   oldRedirects = lib.concatStringsSep "\n" (map