about summary refs log tree commit diff
path: root/users/sterni/machines/ingeborg/irccat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/sterni/machines/ingeborg/irccat.nix')
-rw-r--r--users/sterni/machines/ingeborg/irccat.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/users/sterni/machines/ingeborg/irccat.nix b/users/sterni/machines/ingeborg/irccat.nix
new file mode 100644
index 0000000000..0c40f15e33
--- /dev/null
+++ b/users/sterni/machines/ingeborg/irccat.nix
@@ -0,0 +1,23 @@
+{ depot, config, pkgs, lib, ... }:
+
+{
+  imports = [
+    (depot.path.origSrc + "/ops/modules/irccat.nix")
+  ];
+
+  config = {
+    services.depot.irccat = {
+      enable = true;
+      secretsFile = builtins.toFile "empty.json" "{}"; # TODO(sterni): register
+      config = {
+        tcp.listen = ":4722"; # ircc
+        irc = {
+          server = "irc.hackint.org:6697";
+          tls = true;
+          nick = config.networking.hostName;
+          realname = "irccat";
+        };
+      };
+    };
+  };
+}