about summary refs log tree commit diff
path: root/users/sterni/machines/edwin/http/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/sterni/machines/edwin/http/nginx.nix')
-rw-r--r--users/sterni/machines/edwin/http/nginx.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/users/sterni/machines/edwin/http/nginx.nix b/users/sterni/machines/edwin/http/nginx.nix
new file mode 100644
index 0000000000..7c99cdd150
--- /dev/null
+++ b/users/sterni/machines/edwin/http/nginx.nix
@@ -0,0 +1,28 @@
+{ ... }:
+
+{
+  config = {
+    users = {
+      users.http = {
+        isSystemUser = true;
+        group = "http";
+      };
+
+      groups.http = { };
+    };
+
+    services.nginx = {
+      enable = true;
+      recommendedTlsSettings = true;
+      recommendedGzipSettings = true;
+      recommendedProxySettings = true;
+
+      user = "http";
+      group = "http";
+
+      appendHttpConfig = ''
+        charset utf-8;
+      '';
+    };
+  };
+}