about summary refs log tree commit diff
path: root/users/sterni/machines/edwin/http/fcgiwrap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/sterni/machines/edwin/http/fcgiwrap.nix')
-rw-r--r--users/sterni/machines/edwin/http/fcgiwrap.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/users/sterni/machines/edwin/http/fcgiwrap.nix b/users/sterni/machines/edwin/http/fcgiwrap.nix
new file mode 100644
index 0000000000..19696d85d4
--- /dev/null
+++ b/users/sterni/machines/edwin/http/fcgiwrap.nix
@@ -0,0 +1,15 @@
+{ ... }:
+
+{
+  imports = [
+    ./nginx.nix
+  ];
+
+  config.services.fcgiwrap = {
+    enable = true;
+    socketType = "unix";
+    socketAddress = "/run/fcgiwrap.sock";
+    user = "http";
+    group = "http";
+  };
+}