about summary refs log tree commit diff
path: root/users/grfn/system/system/machines/ogopogo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/system/machines/ogopogo.nix')
-rw-r--r--users/grfn/system/system/machines/ogopogo.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/grfn/system/system/machines/ogopogo.nix b/users/grfn/system/system/machines/ogopogo.nix
index d6b70d834fab..af7075a97f92 100644
--- a/users/grfn/system/system/machines/ogopogo.nix
+++ b/users/grfn/system/system/machines/ogopogo.nix
@@ -137,4 +137,13 @@
         mode = "0440";
       };
     };
+
+  nix.settings.substituters = [ "ssh://grfn@172.16.0.5" ];
+  nix.settings.trusted-substituters = [ "ssh://grfn@172.16.0.5" ];
+  programs.ssh.knownHosts.mugwump = {
+    extraHostNames = [ "172.16.0.5" ];
+    publicKeyFile = pkgs.writeText "mugwump.pub" ''
+      ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFE2fxPgWO+zeQoLBTgsgxP7Vg7QNHlrQ+Rb3fHFTomB
+    '';
+  };
 }