about summary refs log tree commit diff
path: root/users/grfn/system/home/platforms/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/platforms/linux.nix')
-rw-r--r--users/grfn/system/home/platforms/linux.nix93
1 files changed, 0 insertions, 93 deletions
diff --git a/users/grfn/system/home/platforms/linux.nix b/users/grfn/system/home/platforms/linux.nix
deleted file mode 100644
index 92924e4199..0000000000
--- a/users/grfn/system/home/platforms/linux.nix
+++ /dev/null
@@ -1,93 +0,0 @@
-{ config, pkgs, ... }:
-
-let
-
-  depot = config.lib.depot;
-
-in
-
-{
-  imports = [
-    ../modules/alacritty.nix
-    ../modules/alsi.nix
-    ../modules/development.nix
-    ../modules/emacs.nix
-    ../modules/email.nix
-    ../modules/firefox.nix
-    ../modules/games.nix
-    ../modules/obs.nix
-    ../modules/i3.nix
-    ../modules/shell.nix
-    ../modules/tarsnap.nix
-    ../modules/vim.nix
-  ];
-
-  xsession.enable = true;
-
-  home.packages = with pkgs; [
-    (import (fetchTarball "https://github.com/ashkitten/nixpkgs/archive/init-glimpse.tar.gz") {}).glimpse
-
-    # Desktop stuff
-    arandr
-    firefox
-    feh
-    chromium
-    xclip
-    xorg.xev
-    picom
-    peek
-    signal-desktop
-    apvlv # pdf viewer
-    vlc
-    irssi
-    gnutls
-    pandoc
-    barrier
-    depot.tools.nsfv-setup
-
-    # System utilities
-    powertop
-    usbutils
-    pciutils
-    gdmap
-    lsof
-    tree
-    ncat
-    iftop
-
-    # Security
-    gnupg
-    keybase
-    openssl
-    yubikey-manager
-    yubikey-manager-qt
-
-    # Spotify...etc
-    spotify
-    playerctl
-  ];
-
-  services.redshift = {
-    enable = true;
-    provider = "geoclue2";
-  };
-
-  services.pasystray.enable = true;
-
-  services.gpg-agent = {
-    enable = true;
-  };
-
-  gtk = {
-    enable = true;
-    gtk3.bookmarks = [
-      "file:///home/grfn/code"
-    ];
-  };
-
-  programs.zsh.initExtra = ''
-    [[ ! $IN_NIX_SHELL ]] && alsi -l
-  '';
-
-  services.lorri.enable = true;
-}