about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/lib/zshFunctions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/lib/zshFunctions.nix')
-rw-r--r--users/grfn/system/home/modules/lib/zshFunctions.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/users/grfn/system/home/modules/lib/zshFunctions.nix b/users/grfn/system/home/modules/lib/zshFunctions.nix
index 7c39b3478c..228dc6379f 100644
--- a/users/grfn/system/home/modules/lib/zshFunctions.nix
+++ b/users/grfn/system/home/modules/lib/zshFunctions.nix
@@ -6,16 +6,18 @@ with lib;
   options = {
     programs.zsh.functions = mkOption {
       description = "An attribute set that maps function names to their source";
-      default = {};
+      default = { };
       type = with types; attrsOf (either str path);
     };
   };
 
   config.programs.zsh.initExtra = concatStringsSep "\n" (
-    mapAttrsToList (name: funSrc: ''
-      function ${name}() {
-        ${funSrc}
-      }
-    '') config.programs.zsh.functions
+    mapAttrsToList
+      (name: funSrc: ''
+        function ${name}() {
+          ${funSrc}
+        }
+      '')
+      config.programs.zsh.functions
   );
 }