about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/email.nix')
-rw-r--r--users/grfn/system/home/modules/email.nix64
1 files changed, 35 insertions, 29 deletions
diff --git a/users/grfn/system/home/modules/email.nix b/users/grfn/system/home/modules/email.nix
index 0a3e58205b..63dfeeb6f4 100644
--- a/users/grfn/system/home/modules/email.nix
+++ b/users/grfn/system/home/modules/email.nix
@@ -9,7 +9,8 @@ let
     let
       good = upperChars ++ lowerChars ++ stringToCharacters "0123456789-_";
       subst = c: if any (x: x == c) good then c else "-";
-    in stringAsChars subst name;
+    in
+    stringAsChars subst name;
 
   accounts = {
     personal = {
@@ -26,7 +27,8 @@ let
 
   };
 
-in {
+in
+{
   programs.lieer.enable = true;
   programs.notmuch.enable = true;
   services.lieer.enable = true;
@@ -37,16 +39,18 @@ in {
     msmtp
   ];
 
-  systemd.user.services = mapAttrs' (name: account: {
-    name = escapeUnitName "lieer-${name}";
-    value.Service = {
-      ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
+  systemd.user.services = mapAttrs'
+    (name: account: {
+      name = escapeUnitName "lieer-${name}";
+      value.Service = {
+        ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
         ${pkgs.gmailieer}/bin/gmi sync --path ~/mail/${name}
       ''}";
-      Environment = "NOTMUCH_CONFIG=${config.home.sessionVariables.NOTMUCH_CONFIG}";
-    };
+        Environment = "NOTMUCH_CONFIG=${config.home.sessionVariables.NOTMUCH_CONFIG}";
+      };
 
-  }) accounts;
+    })
+    accounts;
 
   # xdg.configFile."notifymuch/notifymuch.cfg".text = generators.toINI {} {
   #   notifymuch = {
@@ -58,30 +62,32 @@ in {
   # };
 
   accounts.email.maildirBasePath = "mail";
-  accounts.email.accounts = mapAttrs (_: params@{ passEntry, ... }: {
-    realName = "Griffin Smith";
-    passwordCommand = "pass ${passEntry}";
+  accounts.email.accounts = mapAttrs
+    (_: params@{ passEntry, ... }: {
+      realName = "Griffin Smith";
+      passwordCommand = "pass ${passEntry}";
 
-    flavor = "gmail.com";
+      flavor = "gmail.com";
 
-    imapnotify = {
-      enable = true;
-      boxes = [ "Inbox" ];
-    };
+      imapnotify = {
+        enable = true;
+        boxes = [ "Inbox" ];
+      };
 
-    gpg = {
-      key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
-      signByDefault = true;
-    };
+      gpg = {
+        key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
+        signByDefault = true;
+      };
 
-    notmuch.enable = true;
-    lieer = {
-      enable = true;
-      sync = {
+      notmuch.enable = true;
+      lieer = {
         enable = true;
-        frequency = "*:*";
+        sync = {
+          enable = true;
+          frequency = "*:*";
+        };
       };
-    };
-    msmtp.enable = true;
-  } // builtins.removeAttrs params ["passEntry"]) accounts;
+      msmtp.enable = true;
+    } // builtins.removeAttrs params [ "passEntry" ])
+    accounts;
 }