about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/development/rust.nix')
-rw-r--r--users/grfn/system/home/modules/development/rust.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/users/grfn/system/home/modules/development/rust.nix b/users/grfn/system/home/modules/development/rust.nix
deleted file mode 100644
index 4ae5bc3bcc..0000000000
--- a/users/grfn/system/home/modules/development/rust.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-
-{
-  home.packages = with pkgs; [
-    rustup
-    rust-analyzer
-    cargo-edit
-    cargo-expand
-    cargo-flamegraph
-    cargo-rr
-    cargo-udeps
-    cargo-bloat
-    sccache
-    evcxr
-  ];
-
-  programs.zsh.shellAliases = {
-    "cg" = "cargo";
-    "cb" = "cargo build";
-    "ct" = "cargo test";
-    "ctw" = "fd -e rs | entr cargo test";
-    "cch" = "cargo check";
-  };
-
-  home.file.".cargo/config".text = ''
-    [build]
-    rustc-wrapper = "${pkgs.sccache}/bin/sccache"
-
-    [target.x86_64-unknown-linux-gnu]
-    linker = "clang"
-    rustflags = ["-C", "link-arg=-fuse-ld=${pkgs.mold}/bin/mold"]
-  '';
-}