about summary refs log tree commit diff
path: root/users/grfn/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/gws.fyi/default.nix')
-rw-r--r--users/grfn/gws.fyi/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/users/grfn/gws.fyi/default.nix b/users/grfn/gws.fyi/default.nix
deleted file mode 100644
index 5ab3614d79..0000000000
--- a/users/grfn/gws.fyi/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-args@{ pkgs, depot, ... }:
-with pkgs;
-let
-  site = import ./site.nix args;
-  resume = import ../resume args;
-  bucket = "s3://gws.fyi";
-  distributionID = "E2ST43JNBH8C64";
-
-  css = runCommand "main.css"
-    {
-      buildInputs = [ pkgs.minify ];
-    } ''
-    minify --type css < ${./main.css} > $out
-  '';
-
-  keys = runCommand "ssh-keys" { } ''
-    touch $out
-    echo "${depot.users.grfn.keys.main}" >> $out
-  '';
-
-  website =
-    runCommand "gws.fyi" { } ''
-      mkdir -p $out
-      cp ${css} $out/main.css
-      cp ${site.index} $out/index.html
-      cp -r ${site.recipes} $out/recipes
-      cp ${resume} $out/resume.pdf
-      cp ${keys} $out/keys
-    '';
-
-in
-(writeShellScript "deploy.sh" ''
-  ${awscli2}/bin/aws --profile personal s3 sync ${website}/ ${bucket}
-  echo "Deployed to http://gws.fyi"
-'') // {
-  inherit website site;
-}