about summary refs log tree commit diff
path: root/users/grfn/bbbg/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/bbbg/shell.nix')
-rw-r--r--users/grfn/bbbg/shell.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/users/grfn/bbbg/shell.nix b/users/grfn/bbbg/shell.nix
deleted file mode 100644
index 48bcd73759..0000000000
--- a/users/grfn/bbbg/shell.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-let
- depot = import ../../.. {};
-in
-with depot.third_party.nixpkgs;
-
-mkShell {
-  buildInputs = [
-    arion
-    depot.third_party.clj2nix
-    clojure
-    openjdk11_headless
-    postgresql_12
-    nix-prefetch-git
-    (writeShellScriptBin "terraform" ''
-      set -e
-      module=$(nix-build ~/code/depot -A users.grfn.bbbg.tf.module)
-      rm -f ~/tfstate/bbbg/*.json
-      cp ''${module}/*.json ~/tfstate/bbbg
-      exec ${depot.users.grfn.bbbg.tf.terraform}/bin/terraform \
-        -chdir=/home/grfn/tfstate/bbbg \
-        "$@"
-    '')
-  ];
-
-  PGHOST = "localhost";
-  PGUSER = "bbbg";
-  PGDATABASE = "bbbg";
-  PGPASSWORD = "password";
-}