about summary refs log tree commit diff
path: root/users/grfn/achilles/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/achilles/shell.nix')
-rw-r--r--users/grfn/achilles/shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/grfn/achilles/shell.nix b/users/grfn/achilles/shell.nix
new file mode 100644
index 0000000000..cdf74db415
--- /dev/null
+++ b/users/grfn/achilles/shell.nix
@@ -0,0 +1,20 @@
+with import (builtins.fetchTarball {
+  url = "https://github.com/nixos/nixpkgs/archive/93a812bb9f9c398bd5b9636ab3674dcfe8cfb884.tar.gz";
+  sha256 = "14zzsgnigd7vjbrpzm1s4qsknm73sci38ss00x96wamz6psaxyah";
+}) {};
+
+mkShell {
+  buildInputs = [
+    clang_11
+    llvm_11.lib
+    llvmPackages_11.bintools
+    llvmPackages_11.clang
+    llvmPackages_11.libclang.lib
+    zlib
+    ncurses
+    libxml2
+    libffi
+    pkg-config
+  ];
+
+}