about summary refs log tree commit diff
path: root/users/glittershark/xanthous/pkg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/xanthous/pkg.nix')
-rw-r--r--users/glittershark/xanthous/pkg.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/glittershark/xanthous/pkg.nix b/users/glittershark/xanthous/pkg.nix
new file mode 100644
index 0000000000..dcf508fa54
--- /dev/null
+++ b/users/glittershark/xanthous/pkg.nix
@@ -0,0 +1,19 @@
+{ nixpkgs ? import ./nixpkgs.nix {}
+,
+}:
+let
+  inherit (builtins) filterSource elem not;
+  inherit (nixpkgs) pkgs;
+  gitignoreSource = (import (pkgs.fetchFromGitHub {
+    owner = "hercules-ci";
+    repo = "gitignore";
+    rev = "f9e996052b5af4032fe6150bba4a6fe4f7b9d698";
+    sha256 = "0jrh5ghisaqdd0vldbywags20m2cxpkbbk5jjjmwaw0gr8nhsafv";
+    # date = 2019-09-18T15:15:15+02:00;
+  }) { inherit (pkgs) lib; }).gitignoreSource;
+in
+import (pkgs.haskellPackages.haskellSrc2nix {
+  name = "xanthous";
+  src = gitignoreSource ./.;
+  extraCabal2nixOptions = "--hpack";
+})