about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/urbint.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/modules/urbint.nix')
-rw-r--r--users/glittershark/system/system/modules/urbint.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/users/glittershark/system/system/modules/urbint.nix b/users/glittershark/system/system/modules/urbint.nix
new file mode 100644
index 0000000000..9790b69dcb
--- /dev/null
+++ b/users/glittershark/system/system/modules/urbint.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, lib, ... }:
+
+with lib;
+
+{
+  virtualisation.docker.enable = true;
+
+  nix = rec {
+    binaryCaches = [ "https://nix.urbinternal.com" ];
+    trustedBinaryCaches = binaryCaches;
+    requireSignedBinaryCaches = false;
+  };
+
+  services.openvpn.servers.urbint = {
+    config = ''
+      config /root/openvpn/urbint.conf
+    '';
+    autoStart = false;
+  };
+
+  users.users."grfn".extraGroups = [ "docker" ];
+
+  services.clamav = {
+    daemon.enable = true;
+    updater = {
+      enable = true;
+      interval = "daily";
+      frequency = 1; # per day
+    };
+  };
+}