about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/yeren.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/machines/yeren.nix')
-rw-r--r--users/glittershark/system/system/machines/yeren.nix125
1 files changed, 0 insertions, 125 deletions
diff --git a/users/glittershark/system/system/machines/yeren.nix b/users/glittershark/system/system/machines/yeren.nix
deleted file mode 100644
index 7bb06716f7..0000000000
--- a/users/glittershark/system/system/machines/yeren.nix
+++ /dev/null
@@ -1,125 +0,0 @@
-{ depot, modulesPath, config, lib, pkgs, ... }:
-
-{
-  imports = [
-    (modulesPath + "/installer/scan/not-detected.nix")
-    ../modules/common.nix
-    ../modules/laptop.nix
-    ../modules/xserver.nix
-    ../modules/fonts.nix
-    ../modules/sound.nix
-    ../modules/tvl.nix
-    ../modules/development.nix
-    ../modules/work/kolide.nix
-  ];
-
-  networking.hostName = "yeren";
-
-  system.stateVersion = "21.03";
-
-  boot = {
-    initrd = {
-      availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
-      kernelModules = [ ];
-
-      luks.devices = {
-        "cryptroot".device = "/dev/disk/by-uuid/dcfbc22d-e0d2-411b-8dd3-96704d3aae2e";
-        "cryptswap".device = "/dev/disk/by-uuid/48b8a8fd-559c-4759-a617-56f221cfaaec";
-      };
-    };
-
-    kernelPackages = pkgs.linuxPackages_latest;
-
-    kernelModules = [ "kvm-intel" ];
-    blacklistedKernelModules = [ "psmouse" ];
-    extraModulePackages = [
-      config.boot.kernelPackages.digimend
-    ];
-    kernelParams = [
-      "i915.preliminary_hw_support=1"
-    ];
-
-    # https://bbs.archlinux.org/viewtopic.php?pid=1933643#p1933643
-    extraModprobeConfig = ''
-      options snd-intel-dspcfg dsp_driver=1
-    '';
-  };
-
-  fileSystems = {
-    "/" = {
-      device = "/dev/mapper/cryptroot";
-      fsType = "btrfs";
-    };
-
-    "/boot" = {
-      device = "/dev/disk/by-uuid/53A9-248B";
-      fsType = "vfat";
-    };
-  };
-
-  swapDevices = [{ device = "/dev/mapper/cryptswap"; }];
-
-  services.xserver = {
-    exportConfiguration = true;
-    extraConfig = ''
-      Section "Device"
-        Identifier  "Intel Graphics"
-        Driver      "intel"
-        Option      "TripleBuffer" "true"
-        Option      "TearFree"     "true"
-        Option      "DRI"          "true"
-        Option      "AccelMethod"  "sna"
-      EndSection
-    '';
-  };
-
-  hardware.firmware = with pkgs; [
-    alsa-firmware
-    sof-firmware
-  ];
-
-  hardware.opengl.extraPackages = with pkgs; [
-    vaapiIntel
-    vaapiVdpau
-    libvdpau-va-gl
-    intel-media-driver
-  ];
-
-  services.fprintd = {
-    enable = true;
-    package = pkgs.fprintd-tod;
-  };
-
-  systemd.services.fprintd.environment.FP_TOD_DRIVERS_DIR =
-    "${pkgs.libfprint-2-tod1-goodix}/usr/lib/libfprint-2/tod-1";
-
-  security.pam.loginLimits = [
-    {
-      domain = "grfn";
-      type = "soft";
-      item = "nofile";
-      value = "65535";
-    }
-  ];
-
-  security.pam.services = {
-    login.fprintAuth = true;
-    sudo.fprintAuth = true;
-    i3lock.fprintAuth = false;
-    i3lock-color.fprintAuth = false;
-    lightdm.fprintAuth = true;
-    lightdm-greeter.fprintAuth = true;
-  };
-
-  hardware.opengl.driSupport32Bit = true;
-
-  hardware.pulseaudio.extraConfig = ''
-    load-module module-remap-source source_name=KompleteAudio6_1 source_properties=device.description=KompleteAudio6Input1 master=alsa_input.usb-Native_Instruments_Komplete_Audio_6_458E0FFD-00.multichannel-input remix=no channels=1 master_channel_map=front-left channel_map=mono
-    load-module module-remap-source source_name=KompleteAudio6_2 source_properties=device.description=KompleteAudio6Input2 master=alsa_input.usb-Native_Instruments_Komplete_Audio_6_458E0FFD-00.multichannel-input remix=no channels=1 master_channel_map=front-right channel_map=mono
-    load-module module-remap-sink sink_name=KompleteAudio6_12 sink_properties=device.description=KompleteAudio6_12 remix=no master=alsa_output.usb-Native_Instruments_Komplete_Audio_6_458E0FFD-00.analog-surround-21 channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right
-  '';
-
-  services.fwupd.enable = true;
-
-  services.tailscale.enable = true;
-}