about summary refs log tree commit diff
path: root/users/glittershark/system/system/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/default.nix')
-rw-r--r--users/glittershark/system/system/default.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/users/glittershark/system/system/default.nix b/users/glittershark/system/system/default.nix
deleted file mode 100644
index 6592eddc08..0000000000
--- a/users/glittershark/system/system/default.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-args @ { depot, pkgs, ... }:
-
-rec {
-  chupacabra = import ./machines/chupacabra.nix;
-
-  chupacabraSystem = (depot.third_party.nixos {
-    configuration = chupacabra;
-  }).system;
-
-  mugwump = import ./machines/mugwump.nix;
-
-  mugwumpSystem = (depot.third_party.nixos {
-    configuration = mugwump;
-  }).system;
-
-  roswell = import ./machines/roswell.nix;
-
-  roswellSystem = (depot.ops.nixos.nixosFor ({ ... }: {
-    imports = [
-      ./machines/roswell.nix
-      "${pkgs.home-manager.src}/nixos"
-    ];
-
-    home-manager.users.grfn = { config, lib, ... }: {
-      imports = [ ../home/machines/roswell.nix ];
-      lib.depot = depot;
-      _module.args.pkgs = lib.mkForce
-        (import pkgs.path
-          (lib.filterAttrs (n: v: v != null) config.nixpkgs));
-    };
-  })).system;
-
-  yeren = import ./machines/yeren.nix;
-
-  yerenSystem = (depot.ops.nixos.nixosFor yeren).system;
-
-  iso = import ./iso.nix args;
-
-  # Build chupacabra in CI
-  meta.targets = [
-    "chupacabraSystem"
-    "mugwumpSystem"
-    "roswellSystem"
-    "yerenSystem"
-
-    "iso"
-  ];
-
-  rebuilder =
-    let
-      depotPath = "/home/grfn/code/depot";
-
-      caseFor = hostname: ''
-        ${hostname})
-          echo "Rebuilding NixOS for //users/glittershark/nixos/${hostname}"
-          system=$(nix-build -E '(import ${depotPath} {}).users.glittershark.system.system.${hostname}' --no-out-link)
-          ;;
-      '';
-    in pkgs.writeShellScriptBin "rebuilder" ''
-      set -ue
-      if [[ $EUID -ne 0 ]]; then
-        echo "Oh no! Only root is allowed to rebuild the system!" >&2
-        exit 1
-      fi
-
-      case $HOSTNAME in
-      ${caseFor "chupacabra"}
-      *)
-        echo "$HOSTNAME is not a known NixOS host!" >&2
-        exit 1
-        ;;
-      esac
-
-      nix-env -p /nix/var/nix/profiles/system --set $system
-      $system/bin/switch-to-configuration switch
-    '';
-}