about summary refs log tree commit diff
path: root/users/glittershark/system/home/platforms/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/platforms/darwin.nix')
-rw-r--r--users/glittershark/system/home/platforms/darwin.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/users/glittershark/system/home/platforms/darwin.nix b/users/glittershark/system/home/platforms/darwin.nix
deleted file mode 100644
index d6b33ba562..0000000000
--- a/users/glittershark/system/home/platforms/darwin.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
-  home.packages = with pkgs; [
-    coreutils
-    gnupg
-    pinentry_mac
-  ];
-
-  home.activation.linkApplications = lib.hm.dag.entryAfter ["writeBoundary"] ''
-    $DRY_RUN_CMD ln -sf $VERBOSE_ARG \
-      ~/.nix-profile/Applications/* ~/Applications/
-  '';
-
-  programs.zsh.initExtra = ''
-    export NIX_PATH=$HOME/.nix-defexpr/channels:$NIX_PATH
-
-    if [[ "$TERM" == "alacritty" ]]; then
-      export TERM="xterm-256color"
-    fi
-  '';
-}