about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/twitter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/twitter.nix')
-rw-r--r--users/glittershark/system/home/modules/twitter.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/users/glittershark/system/home/modules/twitter.nix b/users/glittershark/system/home/modules/twitter.nix
deleted file mode 100644
index 3cb2e90adc..0000000000
--- a/users/glittershark/system/home/modules/twitter.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ pkgs, lib, ... }:
-
-{
-  home.packages = with pkgs; [
-    t
-  ];
-
-  home.sessionVariables = {
-    TWITTER_WHOAMI = "glittershark1";
-  };
-
-  programs.zsh = {
-    shellAliases = {
-      "mytl" = "t tl $TWITTER_WHOAMI";
-    };
-
-    functions = {
-      favelast = "t fave $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
-      rtlast = "t rt $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
-      tthread = "t reply $(t tl -l $TWITTER_WHOAMI | head -n1 | cut -d' ' -f1) $@";
-    };
-  };
-}