about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/lib/zshFunctions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/lib/zshFunctions.nix')
-rw-r--r--users/glittershark/system/home/modules/lib/zshFunctions.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/users/glittershark/system/home/modules/lib/zshFunctions.nix b/users/glittershark/system/home/modules/lib/zshFunctions.nix
deleted file mode 100644
index 7c39b3478c..0000000000
--- a/users/glittershark/system/home/modules/lib/zshFunctions.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
-  options = {
-    programs.zsh.functions = mkOption {
-      description = "An attribute set that maps function names to their source";
-      default = {};
-      type = with types; attrsOf (either str path);
-    };
-  };
-
-  config.programs.zsh.initExtra = concatStringsSep "\n" (
-    mapAttrsToList (name: funSrc: ''
-      function ${name}() {
-        ${funSrc}
-      }
-    '') config.programs.zsh.functions
-  );
-}