about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/development/rust.nix')
-rw-r--r--users/glittershark/system/home/modules/development/rust.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/glittershark/system/home/modules/development/rust.nix b/users/glittershark/system/home/modules/development/rust.nix
index 17bda9c746..29eda82dc1 100644
--- a/users/glittershark/system/home/modules/development/rust.nix
+++ b/users/glittershark/system/home/modules/development/rust.nix
@@ -1,8 +1,16 @@
 { config, lib, pkgs, ... }:
 
+
 {
   home.packages = with pkgs; [
     rustup
     rust-analyzer
+    cargo-edit
   ];
+
+  programs.zsh.shellAliases = {
+    "cg" = "cargo";
+    "cb" = "cargo build";
+    "ct" = "cargo test";
+  };
 }