about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/alacritty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/alacritty.nix')
-rw-r--r--users/glittershark/system/home/modules/alacritty.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/users/glittershark/system/home/modules/alacritty.nix b/users/glittershark/system/home/modules/alacritty.nix
deleted file mode 100644
index 67d6638a31..0000000000
--- a/users/glittershark/system/home/modules/alacritty.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-{
-  programs.alacritty = {
-    enable = true;
-    settings = {
-      font.size = 6;
-      font.normal.family = "Meslo LGSDZ Nerd Font";
-
-      draw_bold_text_with_bright_colors = false;
-
-      key_bindings = [
-        {
-          key = "Escape";
-          mods = "Control";
-          action = "ToggleViMode";
-        }
-      ];
-
-      colors = with import ../common/solarized.nix; rec {
-        # Default colors
-        primary = {
-          background = base3;
-          foreground = base00;
-        };
-
-        cursor = {
-          text = base3;
-          cursor = base00;
-        };
-
-        # Normal colors
-        normal = {
-          inherit red green yellow blue magenta cyan;
-          black = base02;
-          white = base2;
-        };
-
-        # Bright colors
-        # bright = normal;
-        bright = {
-          black = base03;
-          red = orange;
-          green = base01;
-          yellow = base00;
-          blue = base0;
-          magenta = violet;
-          cyan = base1;
-          white = base3;
-        };
-
-        vi_mode_cursor.cursor = red;
-      };
-    };
-  };
-}