about summary refs log tree commit diff
path: root/users/glittershark/system/home/machines/yeren.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/machines/yeren.nix')
-rw-r--r--users/glittershark/system/home/machines/yeren.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/users/glittershark/system/home/machines/yeren.nix b/users/glittershark/system/home/machines/yeren.nix
index bcb1d188f4..70154e4845 100644
--- a/users/glittershark/system/home/machines/yeren.nix
+++ b/users/glittershark/system/home/machines/yeren.nix
@@ -22,6 +22,29 @@ in
   home.packages = with pkgs; [
     zoom-us
     slack
+    mysql
+    graphviz
+
+    (discord.override rec {
+      version = "0.0.13";
+      src = fetchurl {
+        url = "https://dl.discordapp.net/apps/linux/${version}/discord-${version}.tar.gz";
+        sha256 = "0d5z6cbj9dg3hjw84pyg75f8dwdvi2mqxb9ic8dfqzk064ssiv7y";
+      };
+    })
+
+    steam
+
+    (awscli2.overridePythonAttrs (oldAttrs: {
+      postPatch = ''
+        substituteInPlace setup.py \
+          --replace 'colorama>=0.2.5,<0.4.4' 'colorama'  \
+          --replace 'wcwidth<0.2.0' 'colorama' \
+          --replace 'cryptography>=2.8.0,<=2.9.0' 'cryptography' \
+          --replace 'docutils>=0.10,<0.16' 'docutils' \
+          --replace 'ruamel.yaml>=0.15.0,<0.16.0' 'ruamel.yaml'
+      '';
+    }))
   ];
 
   systemd.user.services.laptop-keyboard = {