about summary refs log tree commit diff
path: root/users/glittershark/system/home/machines/chupacabra.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/machines/chupacabra.nix')
-rw-r--r--users/glittershark/system/home/machines/chupacabra.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/users/glittershark/system/home/machines/chupacabra.nix b/users/glittershark/system/home/machines/chupacabra.nix
index 105882ba57..39478c672b 100644
--- a/users/glittershark/system/home/machines/chupacabra.nix
+++ b/users/glittershark/system/home/machines/chupacabra.nix
@@ -51,10 +51,10 @@ in {
     (writeShellScriptBin "rebuild-mugwump" ''
       set -eo pipefail
       cd ~/code/depot
-      nix build -f . users.glittershark.system.system.mugwumpSystem -o mugwump
+      nix build -f . users.glittershark.system.system.mugwumpSystem -o /tmp/mugwump
       nix copy -f . users.glittershark.system.system.mugwumpSystem \
         --to ssh://mugwump
-      system=$(readlink -ef mugwump)
+      system=$(readlink -ef /tmp/mugwump)
       ssh mugwump sudo nix-env -p /nix/var/nix/profiles/system --set $system
       ssh mugwump sudo $system/bin/switch-to-configuration switch
     '')