about summary refs log tree commit diff
path: root/users/glittershark/system/home/machines/chupacabra.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/machines/chupacabra.nix')
-rw-r--r--users/glittershark/system/home/machines/chupacabra.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/users/glittershark/system/home/machines/chupacabra.nix b/users/glittershark/system/home/machines/chupacabra.nix
deleted file mode 100644
index 04f34ccbc4..0000000000
--- a/users/glittershark/system/home/machines/chupacabra.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ pkgs, lib, config, ... }:
-
-with lib;
-
-let
-  laptopKeyboardId = "25";
-in {
-  imports = [
-    ../platforms/linux.nix
-    ../modules/common.nix
-    ../modules/games.nix
-    ../modules/rtlsdr.nix
-    ../modules/ptt.nix
-  ];
-
-  # for when hacking
-  programs.home-manager.path = "/home/grfn/code/home-manager";
-  programs.home-manager.enable = true;
-  home.stateVersion = "19.09";
-
-  system.machine = {
-    wirelessInterface = "wlp59s0";
-    i3FontSize = 9;
-  };
-
-  systemd.user.services.laptop-keyboard = {
-    Unit = {
-      Description = "Swap caps+escape and alt+super, but only on the built-in laptop keyboard";
-      After = [ "graphical-session-pre.target" ];
-      PartOf = [ "graphical-session.target" ];
-    };
-
-    Install = { WantedBy = [ "graphical-session.target" ]; };
-
-    Service = {
-      Type = "oneshot";
-      RemainAfterExit = true;
-      ExecStart = (
-        "${pkgs.xorg.setxkbmap}/bin/setxkbmap "
-          + "-device ${laptopKeyboardId} "
-          + "-option caps:swapescape "
-          + "-option compose:ralt "
-          + "-option altwin:swap_alt_win"
-      );
-    };
-  };
-
-  home.packages = with pkgs; [
-    steam
-    xorg.libxcb
-  ];
-
-  xsession.windowManager.i3.config.keybindings.F7 = "exec lock";
-}