about summary refs log tree commit diff
path: root/users/aspen/xanthous/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/xanthous/shell.nix')
-rw-r--r--users/aspen/xanthous/shell.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/users/aspen/xanthous/shell.nix b/users/aspen/xanthous/shell.nix
new file mode 100644
index 0000000000..2c41cb4aa8
--- /dev/null
+++ b/users/aspen/xanthous/shell.nix
@@ -0,0 +1,23 @@
+let
+  depot = import ../../../. { };
+  inherit (depot) third_party;
+  pkgs = third_party.nixpkgs;
+in
+
+(pkgs.haskell.packages.ghc8107.extend (pkgs.haskell.lib.packageSourceOverrides {
+  xanthous = third_party.gitignoreSource ./.;
+})).shellFor {
+  packages = p: [ p.xanthous ];
+  withHoogle = true;
+  doBenchmark = true;
+  buildInputs = (with pkgs.haskell.packages.ghc8107; [
+    cabal-install
+    ghc-prof-flamegraph
+    hp2pretty
+    hlint
+    haskell-language-server
+    cabal2nix
+  ]) ++ (with pkgs; [
+    qpdf
+  ]);
+}