about summary refs log tree commit diff
path: root/users/aspen/xanthous/server/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/xanthous/server/shell.nix')
-rw-r--r--users/aspen/xanthous/server/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/users/aspen/xanthous/server/shell.nix b/users/aspen/xanthous/server/shell.nix
new file mode 100644
index 0000000000..e01c0316a6
--- /dev/null
+++ b/users/aspen/xanthous/server/shell.nix
@@ -0,0 +1,11 @@
+let
+  depot = import ../../../.. { };
+  pkgs = depot.third_party.nixpkgs;
+in
+
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    rustup
+    rust-analyzer
+  ];
+}