about summary refs log tree commit diff
path: root/users/aspen/xanthous/server/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/xanthous/server/default.nix')
-rw-r--r--users/aspen/xanthous/server/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/users/aspen/xanthous/server/default.nix b/users/aspen/xanthous/server/default.nix
new file mode 100644
index 0000000000..572230a56c
--- /dev/null
+++ b/users/aspen/xanthous/server/default.nix
@@ -0,0 +1,24 @@
+args@{ depot ? import ../../../.. { }
+, pkgs ? depot.third_party.nixpkgs
+, ...
+}:
+
+depot.third_party.naersk.buildPackage {
+  name = "xanthous-server";
+  version = "0.0.1";
+  src = depot.third_party.gitignoreSource ./.;
+
+  # Workaround for a potential Nix bug related to restricted eval.
+  # See https://github.com/nix-community/naersk/issues/169
+  root = depot.nix.sparseTree {
+    root = ./.;
+    paths = [
+      ./Cargo.toml
+      ./Cargo.lock
+    ];
+  };
+
+  passthru = {
+    docker = import ./docker.nix args;
+  };
+}