about summary refs log tree commit diff
path: root/users/aspen/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/xanthous/default.nix')
-rw-r--r--users/aspen/xanthous/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/aspen/xanthous/default.nix b/users/aspen/xanthous/default.nix
new file mode 100644
index 0000000000..049c92fb4c
--- /dev/null
+++ b/users/aspen/xanthous/default.nix
@@ -0,0 +1,27 @@
+{ depot ? (import ../../../. { })
+, pkgs ? depot.third_party.nixpkgs
+, ...
+}:
+
+let
+  ignore = depot.third_party.gitignoreSource.gitignoreFilter ./.;
+  src = builtins.path {
+    name = "xanthous-source";
+    path = ./.;
+    filter = path: type:
+      !(type == "directory" && builtins.baseNameOf path == "server")
+      && !(type == "directory" && builtins.baseNameOf path == "docs")
+      && (ignore path type
+      || builtins.baseNameOf path == "package.yaml");
+  };
+  # generated by cabal2nix
+  basePkg = pkgs.haskell.packages.ghc8107.callPackage ./pkg.nix { };
+in
+
+pkgs.haskell.lib.overrideCabal basePkg (default: {
+  inherit src;
+  version = "canon";
+  configureFlags = [
+    "--ghc-option=-Wall --ghc-option=-Werror"
+  ] ++ (default.configureFlags or [ ]);
+})