about summary refs log tree commit diff
path: root/users/aspen/system/system/machines/roswell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/system/machines/roswell.nix')
-rw-r--r--users/aspen/system/system/machines/roswell.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/aspen/system/system/machines/roswell.nix b/users/aspen/system/system/machines/roswell.nix
new file mode 100644
index 0000000000..da62eec93e
--- /dev/null
+++ b/users/aspen/system/system/machines/roswell.nix
@@ -0,0 +1,27 @@
+{ depot, config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports = [
+    ../modules/common.nix
+    ../modules/development.nix
+    "${modulesPath}/installer/scan/not-detected.nix"
+    "${modulesPath}/virtualisation/amazon-image.nix"
+  ];
+
+  system.stateVersion = "22.05";
+
+  networking.hostName = "roswell";
+
+  boot.loader.systemd-boot.enable = lib.mkForce false;
+  boot.loader.efi.canTouchEfiVariables = lib.mkForce false;
+
+  services.openssh.settings.PasswordAuthentication = false;
+
+  services.tailscale.enable = true;
+
+  security.sudo.wheelNeedsPassword = false;
+
+  environment.systemPackages = with pkgs; [
+    cloud-utils
+  ];
+}