about summary refs log tree commit diff
path: root/users/aspen/system/system/machines/bumblebee.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/system/machines/bumblebee.nix')
-rw-r--r--users/aspen/system/system/machines/bumblebee.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/users/aspen/system/system/machines/bumblebee.nix b/users/aspen/system/system/machines/bumblebee.nix
new file mode 100644
index 0000000000..8bb52f75f0
--- /dev/null
+++ b/users/aspen/system/system/machines/bumblebee.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+{
+  imports = [
+    ../modules/reusable/battery.nix
+  ];
+
+  networking.hostName = "bumblebee";
+
+  powerManagement = {
+    enable = true;
+    cpuFreqGovernor = "powersave";
+    powertop.enable = true;
+  };
+
+  # Hibernate on low battery
+  laptop.onLowBattery = {
+    enable = true;
+    action = "hibernate";
+    thresholdPercentage = 5;
+  };
+
+  services.xserver.xkb.options = "caps:swapescape";
+}