about summary refs log tree commit diff
path: root/users/aspen/system/system/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/system/iso.nix')
-rw-r--r--users/aspen/system/system/iso.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/users/aspen/system/system/iso.nix b/users/aspen/system/system/iso.nix
new file mode 100644
index 0000000000..ef5d3ed78b
--- /dev/null
+++ b/users/aspen/system/system/iso.nix
@@ -0,0 +1,22 @@
+{ depot, lib, pkgs, ... }:
+
+let
+  configuration = { ... }: {
+    imports = [
+      (pkgs.path + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
+      (pkgs.path + "/nixos/modules/installer/cd-dvd/channel.nix")
+    ];
+
+    networking.networkmanager.enable = true;
+    networking.useDHCP = false;
+    networking.firewall.enable = false;
+    networking.wireless.enable = lib.mkForce false;
+
+    # TODO(aspen): enabling this (in the minimal profile) fails the iso build,
+    # since gtk+3 needs to be built which fails due to cairo without xlibs
+    environment.noXlibs = false;
+  };
+in
+(depot.third_party.nixos {
+  inherit configuration;
+}).config.system.build.isoImage