about summary refs log tree commit diff
path: root/users/aspen/system/home/platforms/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/platforms/darwin.nix')
-rw-r--r--users/aspen/system/home/platforms/darwin.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/users/aspen/system/home/platforms/darwin.nix b/users/aspen/system/home/platforms/darwin.nix
new file mode 100644
index 0000000000..f98b80f269
--- /dev/null
+++ b/users/aspen/system/home/platforms/darwin.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+  config = {
+    home.packages = with pkgs; [
+      coreutils
+      gnupg
+      pinentry_mac
+    ];
+
+    home.activation.linkApplications = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
+      $DRY_RUN_CMD ln -sf $VERBOSE_ARG \
+        ~/.nix-profile/Applications/* ~/Applications/
+    '';
+
+    programs.zsh.initExtra = ''
+      export NIX_PATH=$HOME/.nix-defexpr/channels:$NIX_PATH
+
+      if [[ "$TERM" == "alacritty" ]]; then
+        export TERM="xterm-256color"
+      fi
+    '';
+  };
+}