about summary refs log tree commit diff
path: root/users/aspen/system/home/modules/development/ocaml.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/modules/development/ocaml.nix')
-rw-r--r--users/aspen/system/home/modules/development/ocaml.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/aspen/system/home/modules/development/ocaml.nix b/users/aspen/system/home/modules/development/ocaml.nix
new file mode 100644
index 0000000000..5dcdd8980e
--- /dev/null
+++ b/users/aspen/system/home/modules/development/ocaml.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }:
+
+{
+  home.packages = with pkgs; [
+    ocaml
+
+    # ocamlPackages.merlin
+    # ocamlPackages.utop
+    # ocamlPackages.ocp-indent
+    # ocamlPackages.ocamlformat
+  ];
+
+  programs.opam = {
+    enable = true;
+    enableZshIntegration = true;
+  };
+}