about summary refs log tree commit diff
path: root/users/aspen/system/home/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/modules/desktop.nix')
-rw-r--r--users/aspen/system/home/modules/desktop.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/users/aspen/system/home/modules/desktop.nix b/users/aspen/system/home/modules/desktop.nix
new file mode 100644
index 0000000000..e1841cd3c3
--- /dev/null
+++ b/users/aspen/system/home/modules/desktop.nix
@@ -0,0 +1,40 @@
+{ config, lib, pkgs, ... }:
+
+# Things that only work in the presence of a linux desktop environment
+
+{
+  imports = [
+    ./i3.nix
+    ./alacritty.nix
+  ];
+
+  home.packages = with pkgs; [
+    (writeShellApplication {
+      name = "edit-input";
+
+      runtimeInputs = [ xdotool xclip ];
+      text = ''
+        set -euo pipefail
+
+        sleep 0.2
+        xdotool key ctrl+a ctrl+c
+        xclip -out -selection clipboard > /tmp/EDIT
+        emacsclient -c /tmp/EDIT
+        xclip -in -selection clipboard < /tmp/EDIT
+        sleep 0.2
+        xdotool key ctrl+v
+        rm /tmp/EDIT
+      '';
+    })
+  ];
+
+  services.syncthing.tray.enable = true;
+
+  gtk = {
+    enable = true;
+    gtk3.bookmarks = [
+      "file:///home/aspen/code"
+      "file:///home/aspen/notes"
+    ];
+  };
+}