about summary refs log tree commit diff
path: root/users/aspen/system/home/modules/depot-inbox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/modules/depot-inbox.nix')
-rw-r--r--users/aspen/system/home/modules/depot-inbox.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/users/aspen/system/home/modules/depot-inbox.nix b/users/aspen/system/home/modules/depot-inbox.nix
new file mode 100644
index 000000000000..0694e6db2855
--- /dev/null
+++ b/users/aspen/system/home/modules/depot-inbox.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, ... }:
+
+let
+  depot = config.lib.depot;
+in
+
+{
+  systemd.user = {
+    services.sync-depot-public-inbox = {
+      Service.ExecStart = pkgs.writeShellScript "sync-depot-public-inbox" ''
+        ${depot.tools.fetch-depot-inbox}/bin/fetch-depot-inbox \
+          /home/aspen/mail/tvl/
+        ${pkgs.notmuch}/bin/notmuch new
+      '';
+    };
+
+    timers.sync-depot-public-inbox = {
+      Unit.Description = "Sync the depot public inbox";
+      Timer = {
+        OnCalendar = "*:*";
+        Unit = "sync-depot-public-inbox.service";
+      };
+      Install.WantedBy = [ "timers.target" ];
+    };
+  };
+}