about summary refs log tree commit diff
path: root/users/aspen/system/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/home.nix')
-rw-r--r--users/aspen/system/home/home.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/aspen/system/home/home.nix b/users/aspen/system/home/home.nix
new file mode 100644
index 0000000000..39045c147d
--- /dev/null
+++ b/users/aspen/system/home/home.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }:
+
+{
+  imports = [
+    (throw "Pick a machine from ./machines")
+  ];
+
+  # Let Home Manager install and manage itself.
+  programs.home-manager.enable = true;
+
+  # This value determines the Home Manager release that your
+  # configuration is compatible with. This helps avoid breakage
+  # when a new Home Manager release introduces backwards
+  # incompatible changes.
+  #
+  # You can update Home Manager without changing this value. See
+  # the Home Manager release notes for a list of state version
+  # changes in each release.
+  home.stateVersion = "19.09";
+}