about summary refs log tree commit diff
path: root/users/aspen/pkgs/py3status.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/pkgs/py3status.nix')
-rw-r--r--users/aspen/pkgs/py3status.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/users/aspen/pkgs/py3status.nix b/users/aspen/pkgs/py3status.nix
new file mode 100644
index 0000000000..89f52d9674
--- /dev/null
+++ b/users/aspen/pkgs/py3status.nix
@@ -0,0 +1,12 @@
+{ pkgs, ... }:
+
+pkgs.python3Packages.py3status.overridePythonAttrs (old: rec {
+  name = "${pname}-${old.version}";
+  pname = "py3status-glittershark";
+  src = pkgs.fetchFromGitHub {
+    owner = "glittershark";
+    repo = "py3status";
+    rev = "f243be1458cdabd5a7524adb76b5db99006c810c";
+    sha256 = "0ffmv91562yk0wigriw4d5nfg2b32wqx8x78qvdqkawzvgbwrwvl";
+  };
+})