about summary refs log tree commit diff
path: root/users/aspen/pkgs/notmuch-extract-patch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/pkgs/notmuch-extract-patch.nix')
-rw-r--r--users/aspen/pkgs/notmuch-extract-patch.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/aspen/pkgs/notmuch-extract-patch.nix b/users/aspen/pkgs/notmuch-extract-patch.nix
new file mode 100644
index 0000000000..7f00f925ec
--- /dev/null
+++ b/users/aspen/pkgs/notmuch-extract-patch.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+let
+  inherit (pkgs) lib;
+  src = pkgs.fetchurl {
+    url = "https://raw.githubusercontent.com/aaptel/notmuch-extract-patch/f732a53e12a7c91a06755ebfab2007adc9b3063b/notmuch-extract-patch";
+    sha256 = "0nawkl04sj7psw6ikzay7kydj3dhd0fkwghcsf5rzaw4bmp4kbax";
+  };
+
+in
+pkgs.runCommand "notmuch-extract-patch"
+{
+  buildInputs = [ pkgs.python3 ];
+} ''
+  mkdir -p $out/bin
+  install -m 755 ${src} $out/bin/notmuch-extract-patch
+  patchShebangs $out/bin
+''