about summary refs log tree commit diff
path: root/users/aspen/bbbg/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/bbbg/shell.nix')
-rw-r--r--users/aspen/bbbg/shell.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/users/aspen/bbbg/shell.nix b/users/aspen/bbbg/shell.nix
new file mode 100644
index 0000000000..c253a2b9ba
--- /dev/null
+++ b/users/aspen/bbbg/shell.nix
@@ -0,0 +1,29 @@
+let
+  depot = import ../../.. { };
+in
+with depot.third_party.nixpkgs;
+
+mkShell {
+  buildInputs = [
+    arion
+    depot.third_party.clj2nix
+    clojure
+    openjdk11_headless
+    postgresql_12
+    nix-prefetch-git
+    (writeShellScriptBin "terraform" ''
+      set -e
+      module=$(nix-build ~/code/depot -A users.grfn.bbbg.tf.module)
+      rm -f ~/tfstate/bbbg/*.json
+      cp ''${module}/*.json ~/tfstate/bbbg
+      exec ${depot.users.aspen.bbbg.tf.terraform}/bin/terraform \
+        -chdir=/home/grfn/tfstate/bbbg \
+        "$@"
+    '')
+  ];
+
+  PGHOST = "localhost";
+  PGUSER = "bbbg";
+  PGDATABASE = "bbbg";
+  PGPASSWORD = "password";
+}