about summary refs log tree commit diff
path: root/users/Profpatsch/writers/tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/writers/tests.nix')
-rw-r--r--users/Profpatsch/writers/tests.nix58
1 files changed, 51 insertions, 7 deletions
diff --git a/users/Profpatsch/writers/tests.nix b/users/Profpatsch/writers/tests.nix
index 13ddfd10e9..ce9c540162 100644
--- a/users/Profpatsch/writers/tests.nix
+++ b/users/Profpatsch/writers/tests.nix
@@ -1,31 +1,75 @@
-{ depot, pkgs, python3, python3Lib }:
+{ depot, pkgs, python3, python3Lib, rustSimpleLib, rustSimple }:
 
 let
-  transitiveLib = python3Lib {
+  run = drv: depot.nix.runExecline.local "run-${drv.name}" {} [
+    "if" [ drv ]
+    "importas" "out" "out"
+    "${pkgs.coreutils}/bin/touch" "$out"
+  ];
+
+  pythonTransitiveLib = python3Lib {
     name = "transitive";
   } ''
     def transitive(s):
       return s + " 1 2 3"
   '';
 
-  testLib = python3Lib {
+  pythonTestLib = python3Lib {
     name = "test_lib";
-    libraries = _: [ transitiveLib ];
+    libraries = _: [ pythonTransitiveLib ];
   } ''
     import transitive
     def test():
       return transitive.transitive("test")
   '';
 
-  pythonWithLib = python3 "python-with-lib" {
-    libraries = _: [ testLib ];
+  pythonWithLib = run (python3 {
+    name = "python-with-lib";
+    libraries = _: [ pythonTestLib ];
   } ''
     import test_lib
 
     assert(test_lib.test() == "test 1 2 3")
+  '');
+
+
+  rustTransitiveLib = rustSimpleLib {
+    name = "transitive";
+  } ''
+    pub fn transitive(s: &str) -> String {
+      let mut new = s.to_string();
+      new.push_str(" 1 2 3");
+      new
+    }
   '';
 
+  rustTestLib = rustSimpleLib {
+    name = "test_lib";
+    dependencies = [ rustTransitiveLib ];
+  } ''
+    extern crate transitive;
+    use transitive::{transitive};
+    pub fn test() -> String {
+      transitive("test")
+    }
+  '';
+
+  rustWithLib = run (rustSimple {
+    name = "rust-with-lib";
+    dependencies = [ rustTestLib ];
+  } ''
+    extern crate test_lib;
+
+    fn main() {
+      assert_eq!(test_lib::test(), String::from("test 1 2 3"));
+    }
+  '');
+
+
 in {
   inherit
-    pythonWithLib;
+    pythonWithLib
+    rustTransitiveLib
+    rustWithLib
+    ;
 }