about summary refs log tree commit diff
path: root/users/Profpatsch/netstring/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/netstring/tests/default.nix')
-rw-r--r--users/Profpatsch/netstring/tests/default.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/users/Profpatsch/netstring/tests/default.nix b/users/Profpatsch/netstring/tests/default.nix
index b9fb5835e5..f64beb9e92 100644
--- a/users/Profpatsch/netstring/tests/default.nix
+++ b/users/Profpatsch/netstring/tests/default.nix
@@ -2,15 +2,10 @@
 
 let
 
-  inherit (depot.users.Profpatsch.netstring)
-    python-netstring
-    rust-netstring
-    ;
-
   python-netstring-test = depot.users.Profpatsch.writers.python3 {
     name = "python-netstring-test";
     libraries = p: [
-      python-netstring
+      depot.users.Profpatsch.netstring.python-netstring
     ];
   } ''
     import netstring
@@ -38,10 +33,10 @@ let
     )
   '';
 
-  rust-netstring-test = depot.users.Profpatsch.writers.rustSimple {
+  rust-netstring-test = depot.nix.writers.rustSimple {
     name = "rust-netstring-test";
     dependencies = [
-      rust-netstring
+      depot.users.Profpatsch.netstring.rust-netstring
     ];
   } ''
     extern crate netstring;