about summary refs log tree commit diff
path: root/users/Profpatsch/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/lib.nix')
-rw-r--r--users/Profpatsch/lib.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/users/Profpatsch/lib.nix b/users/Profpatsch/lib.nix
index db81c2dfe3..1e9652a279 100644
--- a/users/Profpatsch/lib.nix
+++ b/users/Profpatsch/lib.nix
@@ -21,6 +21,19 @@ let
     "pipeline" [ bins.multitee "0-1,2" ] "$@"
   ];
 
+  eprint-stdin-netencode = depot.nix.writeExecline "eprint-stdin-netencode" {} [
+    "pipeline" [
+      # move stdout to 3
+      "fdmove" "3" "1"
+      # the multitee copies stdin to 1 (the other pipeline end) and 3 (the stdout of the outer pipeline block)
+      "pipeline" [ bins.multitee "0-1,3" ]
+      # make stderr the stdout of pretty, merging with the stderr of pretty
+      "fdmove" "-c" "1" "2"
+      depot.users.Profpatsch.netencode.pretty
+    ]
+    "$@"
+  ];
+
   eprintenv = depot.nix.writeExecline "eprintenv" { readNArgs = 1; } [
     "ifelse" [ "fdmove" "-c" "1" "2" bins.printenv "$1" ]
     [ "$@" ]
@@ -43,6 +56,7 @@ in {
     debugExec
     eprintf
     eprint-stdin
+    eprint-stdin-netencode
     eprintenv
     runInEmptyEnv
     ;