about summary refs log tree commit diff
path: root/users/Profpatsch/arglib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/arglib/default.nix')
-rw-r--r--users/Profpatsch/arglib/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/users/Profpatsch/arglib/default.nix b/users/Profpatsch/arglib/default.nix
new file mode 100644
index 0000000000..4f9f8e4cae
--- /dev/null
+++ b/users/Profpatsch/arglib/default.nix
@@ -0,0 +1,40 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  netencode = {
+    rust = depot.users.Profpatsch.writers.rustSimpleLib {
+      name = "arglib-netencode";
+      dependencies = [
+        depot.users.Profpatsch.netencode.netencode-rs
+      ];
+    } ''
+      extern crate netencode;
+
+      use netencode::{T};
+      use std::os::unix::ffi::OsStrExt;
+
+      pub fn arglib_netencode(env: Option<&std::ffi::OsStr>) -> Result<T, String> {
+          let env = match env {
+              None => std::ffi::OsStr::from_bytes("ARGLIB_NETENCODE".as_bytes()),
+              Some(a) => a
+          };
+          match std::env::var_os(env) {
+              None => Err(format!("could not read args, envvar {} not set", env.to_string_lossy())),
+              // TODO: good error handling for the different parser errors
+              Some(soup) => match netencode::parse::t_t(soup.as_bytes()) {
+                  Ok((remainder, t)) => match remainder.is_empty() {
+                      true => Ok(t),
+                      false => Err(format!("there was some unparsed bytes remaining: {:?}", remainder))
+                  },
+                  Err(err) => Err(format!("parsing error: {:?}", err))
+              }
+          }
+      }
+    '';
+  };
+
+in {
+   inherit
+    netencode
+    ;
+}