about summary refs log tree commit diff
path: root/users/Profpatsch/aliases.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/aliases.nix')
-rw-r--r--users/Profpatsch/aliases.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/users/Profpatsch/aliases.nix b/users/Profpatsch/aliases.nix
index 6a1c2c1a63..109de8ce33 100644
--- a/users/Profpatsch/aliases.nix
+++ b/users/Profpatsch/aliases.nix
@@ -72,4 +72,17 @@ depot.nix.readTree.drvTargets {
     "*\${2}*"
     "$@"
   ];
+
+  bell = depot.nix.writeExecline "bell" { } [
+    "if"
+    [
+      "pactl"
+      "upload-sample"
+      "${pkgs.sound-theme-freedesktop}/share/sounds/freedesktop/stereo/complete.oga"
+      "bell-window-system"
+    ]
+    "pactl"
+    "play-sample"
+    "bell-window-system"
+  ];
 }