about summary refs log tree commit diff
path: root/users/Profpatsch/alacritty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/alacritty.nix')
-rw-r--r--users/Profpatsch/alacritty.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/users/Profpatsch/alacritty.nix b/users/Profpatsch/alacritty.nix
new file mode 100644
index 0000000000..56229c9484
--- /dev/null
+++ b/users/Profpatsch/alacritty.nix
@@ -0,0 +1,29 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  bins = depot.nix.getBins pkgs.alacritty [ "alacritty" ];
+
+  config = lib.pipe { } [
+    (_: depot.users.Profpatsch.importDhall.importDhall {
+      root = ./.;
+      files = [
+        "alacritty.dhall"
+        "solarized.dhall"
+      ];
+      main = "alacritty.dhall";
+      deps = [ ];
+    })
+    (lib.generators.toYAML { })
+    (pkgs.writeText "alacritty.conf")
+  ];
+
+
+  alacritty = depot.nix.writeExecline "alacritty" { } [
+    bins.alacritty
+    "--config-file"
+    config
+    "$@"
+  ];
+
+in
+alacritty