about summary refs log tree commit diff
path: root/users/Profpatsch/alacritty.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-02-27T18·48+0100
committerProfpatsch <mail@profpatsch.de>2022-02-28T14·32+0000
commitfd519c825f916d838f87c160425109eb98836e51 (patch)
tree0a2b0326aa798874ebf0ddfe5b187105a75ac03d /users/Profpatsch/alacritty.nix
parent9014804e2c7778e1aaa61f983557680ac563b8a6 (diff)
feat(users/Profpatsch): Basic alacritty dhall configuration r/3877
Change-Id: I73e91a0abeec013445d0b14867e38637b2a9397f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5334
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/alacritty.nix')
-rw-r--r--users/Profpatsch/alacritty.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/users/Profpatsch/alacritty.nix b/users/Profpatsch/alacritty.nix
new file mode 100644
index 0000000000..56229c9484
--- /dev/null
+++ b/users/Profpatsch/alacritty.nix
@@ -0,0 +1,29 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  bins = depot.nix.getBins pkgs.alacritty [ "alacritty" ];
+
+  config = lib.pipe { } [
+    (_: depot.users.Profpatsch.importDhall.importDhall {
+      root = ./.;
+      files = [
+        "alacritty.dhall"
+        "solarized.dhall"
+      ];
+      main = "alacritty.dhall";
+      deps = [ ];
+    })
+    (lib.generators.toYAML { })
+    (pkgs.writeText "alacritty.conf")
+  ];
+
+
+  alacritty = depot.nix.writeExecline "alacritty" { } [
+    bins.alacritty
+    "--config-file"
+    config
+    "$@"
+  ];
+
+in
+alacritty