about summary refs log tree commit diff
path: root/users/Profpatsch/aerc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/aerc.nix')
-rw-r--r--users/Profpatsch/aerc.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/users/Profpatsch/aerc.nix b/users/Profpatsch/aerc.nix
deleted file mode 100644
index 407f224e58..0000000000
--- a/users/Profpatsch/aerc.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ depot, pkgs, lib, ... }:
-
-let
-  aerc-patched = pkgs.aerc.overrideAttrs (old: {
-    patches = old.patches or [ ] ++ [
-      ./aerc-no-config-perms.patch
-    ];
-  });
-
-  bins = depot.nix.getBins aerc-patched [ "aerc" ];
-
-  config =
-    depot.users.Profpatsch.importDhall.importDhall
-      {
-        root = ./.;
-        files = [
-          "aerc.dhall"
-          "dhall/lib.dhall"
-          "ini/ini.dhall"
-        ];
-        main = "aerc.dhall";
-        deps = [
-        ];
-      }
-      {
-        aercFilter = name: "${aerc-patched}/share/aerc/filters/${name}";
-        "Ini/externs" = depot.users.Profpatsch.ini.externs;
-      };
-
-  aerc-config = pkgs.linkFarm "alacritty-config" [
-    {
-      name = "aerc/accounts.conf";
-      path = pkgs.writeText "accounts.conf" config.accounts;
-    }
-    {
-      name = "aerc/aerc.conf";
-      path = pkgs.writeText "aerc.conf" config.aerc;
-    }
-    {
-      name = "aerc/binds.conf";
-      path = pkgs.writeText "binds.conf" config.binds;
-    }
-  ];
-
-  aerc = depot.nix.writeExecline "aerc" { } [
-    "export"
-    "XDG_CONFIG_HOME"
-    aerc-config
-    bins.aerc
-    "$@"
-  ];
-
-in
-aerc