about summary refs log tree commit diff
path: root/tvix/tracing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tracing/default.nix')
-rw-r--r--tvix/tracing/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tvix/tracing/default.nix b/tvix/tracing/default.nix
new file mode 100644
index 0000000000..dd7dc200f2
--- /dev/null
+++ b/tvix/tracing/default.nix
@@ -0,0 +1,11 @@
+{ depot, lib, ... }:
+
+(depot.tvix.crates.workspaceMembers.tvix-tracing.build.override {
+  runTests = true;
+}).overrideAttrs (old: rec {
+  meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
+  passthru = depot.tvix.utils.mkFeaturePowerset {
+    inherit (old) crateName;
+    features = [ "otlp" "tracy" ];
+  };
+})