about summary refs log tree commit diff
path: root/tvix/tracing/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tracing/Cargo.toml')
-rw-r--r--tvix/tracing/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/tvix/tracing/Cargo.toml b/tvix/tracing/Cargo.toml
new file mode 100644
index 000000000000..acd968eb231f
--- /dev/null
+++ b/tvix/tracing/Cargo.toml
@@ -0,0 +1,54 @@
+[package]
+name = "tvix-tracing"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+lazy_static = { workspace = true }
+tracing = { workspace = true, features = ["max_level_trace", "release_max_level_debug"] }
+tracing-subscriber = { workspace = true, features = ["env-filter"] }
+indicatif = { workspace = true }
+tracing-indicatif = { workspace = true }
+tokio = { workspace = true, features = ["sync", "rt"] }
+thiserror = { workspace = true }
+
+tracing-opentelemetry = { workspace = true, optional = true }
+opentelemetry = { workspace = true, optional = true }
+opentelemetry-otlp = { workspace = true, optional = true }
+opentelemetry_sdk = { workspace = true, features = ["rt-tokio"], optional = true }
+tracing-tracy = { workspace = true, features = ["flush-on-exit"], optional = true }
+opentelemetry-http = { workspace = true, optional = true }
+
+tonic = { workspace = true, optional = true }
+http  = { workspace = true, optional = true }
+
+reqwest-tracing = { workspace = true, optional = true }
+
+axum = { workspace = true, optional = true }
+
+[features]
+default = []
+otlp = [
+  "dep:tracing-opentelemetry",
+  "dep:opentelemetry",
+  "dep:opentelemetry-otlp",
+  "dep:opentelemetry_sdk",
+  "dep:opentelemetry-http",
+  "reqwest-tracing?/opentelemetry_0_22",
+]
+tracy = [
+  "dep:tracing-tracy"
+]
+tonic = [
+  "dep:tonic",
+  "dep:http",
+]
+reqwest = [
+  "dep:reqwest-tracing",
+]
+axum = [
+  "dep:axum",
+]
+
+[lints]
+workspace = true